Unintentional broken compatibility of Ant 1.10.6 with Java 8

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Unintentional broken compatibility of Ant 1.10.6 with Java 8

Jaikiran Pai-2
As you all might know, we released Ant 1.10.6 some days back. That
release was built using Java 11 but targeted to be usable with Java 8
(our minimum requirement runtime that we support). However, due to a bug
in our build and release process, we have broken the compatibility of
this version against Java 8. One such issue has been reported here
https://bz.apache.org/bugzilla/show_bug.cgi?id=63457 and a fix (and a
prevention to hopefully not run into these issues again) is being worked
upon. This obviously will involve a new release of Ant 1.10.x.

This mail is just an advance notice to users who might have been
planning to upgrade their setups to this released version, to wait for a
newer release, if you plan to use this version against Java 8. In the
meantime, you can still try out the 1.10.6 release and report any other
issues that you might run into.

-Jaikiran



signature.asc (849 bytes) Download Attachment