[VOTE] Increase minimum Java version for Ivy to Java7

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[VOTE] Increase minimum Java version for Ivy to Java7

Jan Matèrne
As discussed on this mailing list [1] we should increase the minimum Java
version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
Decisions whether to increase to Java8 after that release should be make
after that release.
According to the bylaws [3] this vote is open for one week (until
26.05.2017).

Here is my +1
Jan

[1]
http://mail-archives.apache.org/mod_mbox/ant-dev/201705.mbox/ajax/%3C87415C1
F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
[2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
[3] http://ant.apache.org/bylaws.html


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Jaikiran Pai
+1

-Jaikiran
On 19-May-2017, at 10:55 AM, Jan Matèrne <[hidden email]> wrote:

As discussed on this mailing list [1] we should increase the minimum Java
version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
Decisions whether to increase to Java8 after that release should be make
after that release.
According to the bylaws [3] this vote is open for one week (until
26.05.2017).

Here is my +1
Jan

[1]
http://mail-archives.apache.org/mod_mbox/ant-dev/201705.mbox/ajax/%3C87415C1
F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
[2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
[3] http://ant.apache.org/bylaws.html


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Maarten Coene-2
In reply to this post by Jan Matèrne
I think we should stick to Java5 as long as Ant 1.9.x is actively maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
Or are there good reasons to increase the minimum Java version, like features that cannot be implemented with Java 5?
But since I don't have the time at the moment to be more active for the community, I will not block any decission made.
So my vote is -0.
Maarten


      Van: Jan Matèrne <[hidden email]>
 Aan: 'Ant Developers List' <[hidden email]>
 Verzonden: vrijdag 19 mei 7:25 2017
 Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
   
As discussed on this mailing list [1] we should increase the minimum Java
version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
Decisions whether to increase to Java8 after that release should be make
after that release.
According to the bylaws [3] this vote is open for one week (until
26.05.2017).

Here is my +1
Jan

[1]
http://mail-archives.apache.org/mod_mbox/ant-dev/201705.mbox/ajax/%3C87415C1
F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
[2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
[3] http://ant.apache.org/bylaws.html


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]



   
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Gintautas Grigelionis
Java 7 implements TLS 1.2; Ivy depends a lot more on network communications
than Ant does.
+1, but please extend the vote to the baseline of IvyDE as well.

2017-05-19 9:03 GMT+02:00 Maarten Coene <[hidden email]>:

> I think we should stick to Java5 as long as Ant 1.9.x is actively
> maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
> Or are there good reasons to increase the minimum Java version, like
> features that cannot be implemented with Java 5?
> But since I don't have the time at the moment to be more active for the
> community, I will not block any decission made.
> So my vote is -0.
> Maarten
>
>
>       Van: Jan Matèrne <[hidden email]>
>  Aan: 'Ant Developers List' <[hidden email]>
>  Verzonden: vrijdag 19 mei 7:25 2017
>  Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
>
> As discussed on this mailing list [1] we should increase the minimum Java
> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> Decisions whether to increase to Java8 after that release should be make
> after that release.
> According to the bylaws [3] this vote is open for one week (until
> 26.05.2017).
>
> Here is my +1
> Jan
>
> [1]
> http://mail-archives.apache.org/mod_mbox/ant-dev/201705.
> mbox/ajax/%3C87415C1
> F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> [2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
> [3] http://ant.apache.org/bylaws.html
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Maarten Coene-2
Yes, but it's not because Ivy is compiled with Java 5 that you cannot run it with Java 7 to have TLS1.2 support.
Maarten

      Van: Gintautas Grigelionis <[hidden email]>
 Aan: Ant Developers List <[hidden email]>; Maarten Coene <[hidden email]>
 Verzonden: vrijdag 19 mei 9:20 2017
 Onderwerp: Re: [VOTE] Increase minimum Java version for Ivy to Java7
   
Java 7 implements TLS 1.2; Ivy depends a lot more on network communications
than Ant does.
+1, but please extend the vote to the baseline of IvyDE as well.

2017-05-19 9:03 GMT+02:00 Maarten Coene <[hidden email]>:

> I think we should stick to Java5 as long as Ant 1.9.x is actively
> maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
> Or are there good reasons to increase the minimum Java version, like
> features that cannot be implemented with Java 5?
> But since I don't have the time at the moment to be more active for the
> community, I will not block any decission made.
> So my vote is -0.
> Maarten
>
>
>      Van: Jan Matèrne <[hidden email]>
>  Aan: 'Ant Developers List' <[hidden email]>
>  Verzonden: vrijdag 19 mei 7:25 2017
>  Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
>
> As discussed on this mailing list [1] we should increase the minimum Java
> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> Decisions whether to increase to Java8 after that release should be make
> after that release.
> According to the bylaws [3] this vote is open for one week (until
> 26.05.2017).
>
> Here is my +1
> Jan
>
> [1]
> http://mail-archives.apache.org/mod_mbox/ant-dev/201705.
> mbox/ajax/%3C87415C1
> F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> [2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
> [3] http://ant.apache.org/bylaws.html
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
>
>

   
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Jaikiran Pai
In reply to this post by Maarten Coene-2
One of the reasons, other than the fact that I haven’t personally seen anyone using Java 5 in development projects or production for many years now, has to do with the development and testing of the project itself.

It’s hard to find a Java 5 runtime to actually test the product against (almost the same with Java 6). Plus the fact that, for enhancements like this one [1] we will end up adding a bit more complexity to the project which can be avoided if we move to a higher version. Add to that the various language level features that we can’t currently use (try with resources, switch statements from string etc…) in the code.

As for using Ivy with Ant 1.9.x, I think the strategy we can follow is to recommend users to use Ivy 2.5.x with Ant 1.10.x (which by the way is Java 8 runtime backed). If however they do want to use Ant 1.9.x version, then ask them to use Ivy 2.4.0.

[1] https://github.com/apache/ant-ivy/pull/19

-Jaikiran

On 19-May-2017, at 12:33 PM, Maarten Coene <[hidden email]> wrote:

I think we should stick to Java5 as long as Ant 1.9.x is actively maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
Or are there good reasons to increase the minimum Java version, like features that cannot be implemented with Java 5?
But since I don't have the time at the moment to be more active for the community, I will not block any decission made.
So my vote is -0.
Maarten


     Van: Jan Matèrne <[hidden email]>
Aan: 'Ant Developers List' <[hidden email]>
Verzonden: vrijdag 19 mei 7:25 2017
Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7

As discussed on this mailing list [1] we should increase the minimum Java
version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
Decisions whether to increase to Java8 after that release should be make
after that release.
According to the bylaws [3] this vote is open for one week (until
26.05.2017).

Here is my +1
Jan

[1]
http://mail-archives.apache.org/mod_mbox/ant-dev/201705.mbox/ajax/%3C87415C1
F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
[2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
[3] http://ant.apache.org/bylaws.html


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Nicolas Lalevée
In reply to this post by Jan Matèrne
+1

Be able to test on an old jvm will be near impossible for me.

Nicolas

> Le 19 mai 2017 à 07:25, Jan Matèrne <[hidden email]> a écrit :
>
> As discussed on this mailing list [1] we should increase the minimum Java
> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> Decisions whether to increase to Java8 after that release should be make
> after that release.
> According to the bylaws [3] this vote is open for one week (until
> 26.05.2017).
>
> Here is my +1
> Jan
>
> [1]
> http://mail-archives.apache.org/mod_mbox/ant-dev/201705.mbox/ajax/%3C87415C1
> F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> [2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
> [3] http://ant.apache.org/bylaws.html
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Dominique Devienne-2
In reply to this post by Jan Matèrne
On Fri, May 19, 2017 at 7:25 AM, Jan Matèrne <[hidden email]> wrote:

> As discussed on this mailing list [1] we should increase the minimum Java
> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
>

+1. --DD

PS: Ivy already has trouble attracting dev attention, so I feel we should
let those making the effort
to work on it not have to jump through hoops by supporting a mostly
obsolete Java5.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Jaikiran Pai
In reply to this post by Gintautas Grigelionis
Not fully familiar with the voting process and don’t know if IvyDE will require a voting thread of its own, but either way +1 for Java 7 for IvyDE too.

-Jaikiran
On 19-May-2017, at 12:50 PM, Gintautas Grigelionis <[hidden email]> wrote:

Java 7 implements TLS 1.2; Ivy depends a lot more on network communications
than Ant does.
+1, but please extend the vote to the baseline of IvyDE as well.

2017-05-19 9:03 GMT+02:00 Maarten Coene <[hidden email]>:

> I think we should stick to Java5 as long as Ant 1.9.x is actively
> maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
> Or are there good reasons to increase the minimum Java version, like
> features that cannot be implemented with Java 5?
> But since I don't have the time at the moment to be more active for the
> community, I will not block any decission made.
> So my vote is -0.
> Maarten
>
>
>      Van: Jan Matèrne <[hidden email]>
> Aan: 'Ant Developers List' <[hidden email]>
> Verzonden: vrijdag 19 mei 7:25 2017
> Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
>
> As discussed on this mailing list [1] we should increase the minimum Java
> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> Decisions whether to increase to Java8 after that release should be make
> after that release.
> According to the bylaws [3] this vote is open for one week (until
> 26.05.2017).
>
> Here is my +1
> Jan
>
> [1]
> http://mail-archives.apache.org/mod_mbox/ant-dev/201705.
> mbox/ajax/%3C87415C1
> F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> [2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
> [3] http://ant.apache.org/bylaws.html
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Nicolas Lalevée
Ant Bylaws is a good read to understand the process
https://ant.apache.org/bylaws.html <https://ant.apache.org/bylaws.html>

Since the initial question is about Ivy only, another vote will be needed for IvyDE.

Nicolas

> Le 20 mai 2017 à 04:47, J Pai <[hidden email]> a écrit :
>
> Not fully familiar with the voting process and don’t know if IvyDE will require a voting thread of its own, but either way +1 for Java 7 for IvyDE too.
>
> -Jaikiran
> On 19-May-2017, at 12:50 PM, Gintautas Grigelionis <[hidden email]> wrote:
>
> Java 7 implements TLS 1.2; Ivy depends a lot more on network communications
> than Ant does.
> +1, but please extend the vote to the baseline of IvyDE as well.
>
> 2017-05-19 9:03 GMT+02:00 Maarten Coene <[hidden email]>:
>
>> I think we should stick to Java5 as long as Ant 1.9.x is actively
>> maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
>> Or are there good reasons to increase the minimum Java version, like
>> features that cannot be implemented with Java 5?
>> But since I don't have the time at the moment to be more active for the
>> community, I will not block any decission made.
>> So my vote is -0.
>> Maarten
>>
>>
>>     Van: Jan Matèrne <[hidden email]>
>> Aan: 'Ant Developers List' <[hidden email]>
>> Verzonden: vrijdag 19 mei 7:25 2017
>> Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
>>
>> As discussed on this mailing list [1] we should increase the minimum Java
>> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
>> Decisions whether to increase to Java8 after that release should be make
>> after that release.
>> According to the bylaws [3] this vote is open for one week (until
>> 26.05.2017).
>>
>> Here is my +1
>> Jan
>>
>> [1]
>> http://mail-archives.apache.org/mod_mbox/ant-dev/201705.
>> mbox/ajax/%3C87415C1
>> F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
>> [2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
>> [3] http://ant.apache.org/bylaws.html
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>>
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Gintautas Grigelionis
Sorry for sloppy suggestion, I did not mean changing the subject. My
intention was to remind about another component which has Ivy as a direct
dependency and that it makes sense to align their baselines.

Gintas

2017-05-20 11:25 GMT+02:00 Nicolas Lalevée <[hidden email]>:

> Ant Bylaws is a good read to understand the process
> https://ant.apache.org/bylaws.html <https://ant.apache.org/bylaws.html>
>
> Since the initial question is about Ivy only, another vote will be needed
> for IvyDE.
>
> Nicolas
>
> > Le 20 mai 2017 à 04:47, J Pai <[hidden email]> a écrit :
> >
> > Not fully familiar with the voting process and don’t know if IvyDE will
> require a voting thread of its own, but either way +1 for Java 7 for IvyDE
> too.
> >
> > -Jaikiran
> > On 19-May-2017, at 12:50 PM, Gintautas Grigelionis <
> [hidden email]> wrote:
> >
> > Java 7 implements TLS 1.2; Ivy depends a lot more on network
> communications
> > than Ant does.
> > +1, but please extend the vote to the baseline of IvyDE as well.
> >
> > 2017-05-19 9:03 GMT+02:00 Maarten Coene <[hidden email].
> invalid>:
> >
> >> I think we should stick to Java5 as long as Ant 1.9.x is actively
> >> maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
> >> Or are there good reasons to increase the minimum Java version, like
> >> features that cannot be implemented with Java 5?
> >> But since I don't have the time at the moment to be more active for the
> >> community, I will not block any decission made.
> >> So my vote is -0.
> >> Maarten
> >>
> >>
> >>     Van: Jan Matèrne <[hidden email]>
> >> Aan: 'Ant Developers List' <[hidden email]>
> >> Verzonden: vrijdag 19 mei 7:25 2017
> >> Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
> >>
> >> As discussed on this mailing list [1] we should increase the minimum
> Java
> >> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> >> Decisions whether to increase to Java8 after that release should be make
> >> after that release.
> >> According to the bylaws [3] this vote is open for one week (until
> >> 26.05.2017).
> >>
> >> Here is my +1
> >> Jan
> >>
> >> [1]
> >> http://mail-archives.apache.org/mod_mbox/ant-dev/201705.
> >> mbox/ajax/%3C87415C1
> >> F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> >> [2] http://ant.apache.org/ivy/history/latest-milestone/
> compatibility.html
> >> [3] http://ant.apache.org/bylaws.html
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: [hidden email]
> >> For additional commands, e-mail: [hidden email]
> >>
> >>
> >>
> >>
> >>
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Gintautas Grigelionis
In reply to this post by Maarten Coene-2
Should we start talking about using HTTP/2? Then we're firmly in Java 8
territory :-)

Gintas

2017-05-19 9:23 GMT+02:00 Maarten Coene <[hidden email]>:

> Yes, but it's not because Ivy is compiled with Java 5 that you cannot run
> it with Java 7 to have TLS1.2 support.
> Maarten
>
>       Van: Gintautas Grigelionis <[hidden email]>
>  Aan: Ant Developers List <[hidden email]>; Maarten Coene <
> [hidden email]>
>  Verzonden: vrijdag 19 mei 9:20 2017
>  Onderwerp: Re: [VOTE] Increase minimum Java version for Ivy to Java7
>
> Java 7 implements TLS 1.2; Ivy depends a lot more on network communications
> than Ant does.
> +1, but please extend the vote to the baseline of IvyDE as well.
>
> 2017-05-19 9:03 GMT+02:00 Maarten Coene <[hidden email]>:
>
> > I think we should stick to Java5 as long as Ant 1.9.x is actively
> > maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
> > Or are there good reasons to increase the minimum Java version, like
> > features that cannot be implemented with Java 5?
> > But since I don't have the time at the moment to be more active for the
> > community, I will not block any decission made.
> > So my vote is -0.
> > Maarten
> >
> >
> >      Van: Jan Matèrne <[hidden email]>
> >  Aan: 'Ant Developers List' <[hidden email]>
> >  Verzonden: vrijdag 19 mei 7:25 2017
> >  Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
> >
> > As discussed on this mailing list [1] we should increase the minimum Java
> > version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> > Decisions whether to increase to Java8 after that release should be make
> > after that release.
> > According to the bylaws [3] this vote is open for one week (until
> > 26.05.2017).
> >
> > Here is my +1
> > Jan
> >
> > [1]
> > http://mail-archives.apache.org/mod_mbox/ant-dev/201705.
> > mbox/ajax/%3C87415C1
> > F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> > [2] http://ant.apache.org/ivy/history/latest-milestone/
> compatibility.html
> > [3] http://ant.apache.org/bylaws.html
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
> >
> >
> >
>
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: [VOTE] Increase minimum Java version for Ivy to Java7

Jan Matèrne (jhm)
> Should we start talking about using HTTP/2? Then we're firmly in Java 8
> territory :-)

While having HTTP/2 support would be a cool thing, I think we should make small steps, and one after the other.
So increase minimum Java version from 1.5 to 1.7, apply some changes, make a release.
Then we could think about moving to Java8, maybe preparing for Java9 ...

Jan


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Matt Sicker
Isn't HTTP 2.0 only in Java 9? Otherwise you need a 3rd party library that
implements the protocol support.

On 22 May 2017 at 02:00, Jan Matèrne (jhm) <[hidden email]> wrote:

> > Should we start talking about using HTTP/2? Then we're firmly in Java 8
> > territory :-)
>
> While having HTTP/2 support would be a cool thing, I think we should make
> small steps, and one after the other.
> So increase minimum Java version from 1.5 to 1.7, apply some changes, make
> a release.
> Then we could think about moving to Java8, maybe preparing for Java9 ...
>
> Jan
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Matt Sicker <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Increase minimum Java version for Ivy to Java7

Gintautas Grigelionis
You're right, full HTTP/2 in JRE is Java 9. What I meant was AEAD crypto
that was introduced in Java 8 JRE. Before that, that's another dependency
on BouncyCastle.

Gintas

2017-05-22 17:42 GMT+02:00 Matt Sicker <[hidden email]>:

> Isn't HTTP 2.0 only in Java 9? Otherwise you need a 3rd party library that
> implements the protocol support.
>
> On 22 May 2017 at 02:00, Jan Matèrne (jhm) <[hidden email]> wrote:
>
> > > Should we start talking about using HTTP/2? Then we're firmly in Java 8
> > > territory :-)
> >
> > While having HTTP/2 support would be a cool thing, I think we should make
> > small steps, and one after the other.
> > So increase minimum Java version from 1.5 to 1.7, apply some changes,
> make
> > a release.
> > Then we could think about moving to Java8, maybe preparing for Java9 ...
> >
> > Jan
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
>
> --
> Matt Sicker <[hidden email]>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[RESULT] [VOTE] Increase minimum Java version for Ivy to Java7

Jan Matèrne (jhm)
In reply to this post by Jan Matèrne
[RESULT] [VOTE] Increase minimum Java version for Ivy to Java7

Here is the result of the vote to increase the minimum Java
version from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0):

+1:
  Jan (binding)
  Jaikiran (non-binding)
  Gintautas (non-binding)
  Nicolas (binding)
  Dominique (binding)

-0:
  Maarten (binding)


So the vote passed and we can use Java7 from now.


Jan


> As discussed on this mailing list [1] we should increase the minimum
> Java version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> Decisions whether to increase to Java8 after that release should be
> make after that release.
> According to the bylaws [3] this vote is open for one week (until
> 26.05.2017).
>
>
> [1]
http://mail-archives.apache.org/mod_mbox/ant-dev/201705.mbox/ajax/%3C87415C1
F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> [2] http://ant.apache.org/ivy/history/latest-milestone/compatibility.html
> [3] http://ant.apache.org/bylaws.html 


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...