build IvyDE

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

build IvyDE

Jan Matèrne
I tried to get the IvyDE build working.

Finally I am getting a

 

[eclipse.buildScript] Some inter-plug-in dependencies have not been
satisfied.

[eclipse.buildScript] Bundle org.apache.ivyde.eclipse.resolvevisualizer:

[eclipse.buildScript]       Missing required plug-in
org.eclipse.zest.core_[1.2.0,2.0.0).

[eclipse.buildScript]       Missing required plug-in
org.eclipse.zest.layouts_[1.1.0,2.0.0).

 

I could download zest via "ant hudson-get-zest"

 

hudson-get-zest:

      [get] Getting:
http://www.eclipse.org/downloads/download.php?file=/tools/gef/downloads/drop
s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://carroll.aset.psu.edu/pub
/eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-zest-3.6.2.zip&mi
rror_id=546

      [get] To:
C:\projekte\apache-ant\ivy-ivyde\dependencies\GEF-zest-3.6.2.zip

      [get]
http://www.eclipse.org/downloads/download.php?file=/tools/gef/downloads/drop
s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://carroll.aset.psu.edu/pub
/eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-zest-3.6.2.zip&mi
rror_id=546 moved to
http://archive.eclipse.org/tools/gef/downloads/drops/3.6.2/R201102251600/GEF
-zest-3.6.2.zip

      [get] .......................

 

BUILD SUCCESSFUL

Total time: 5 seconds

 

 

Some ideas?

 

 

Jan

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: build IvyDE

Gintautas Grigelionis
Did you try to run "ant hudson-prepare"? That's supposed to set up the
entire environment, that is, download PDE and all dependencies (WTP, XSD,
EMF, GEF and Zest) as drops, then unpack the PDE and all drops on top of
that, if my understanding is correct. It also should pick up the latest Ivy
build and update build properties.

Gintas

2017-05-26 14:53 GMT+02:00 Jan Matèrne <[hidden email]>:

> I tried to get the IvyDE build working.
>
> Finally I am getting a
>
>
>
> [eclipse.buildScript] Some inter-plug-in dependencies have not been
> satisfied.
>
> [eclipse.buildScript] Bundle org.apache.ivyde.eclipse.resolvevisualizer:
>
> [eclipse.buildScript]       Missing required plug-in
> org.eclipse.zest.core_[1.2.0,2.0.0).
>
> [eclipse.buildScript]       Missing required plug-in
> org.eclipse.zest.layouts_[1.1.0,2.0.0).
>
>
>
> I could download zest via "ant hudson-get-zest"
>
>
>
> hudson-get-zest:
>
>       [get] Getting:
> http://www.eclipse.org/downloads/download.php?file=/
> tools/gef/downloads/drop
> s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://
> carroll.aset.psu.edu/pub
> /eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-
> zest-3.6.2.zip&mi
> rror_id=546
>
>       [get] To:
> C:\projekte\apache-ant\ivy-ivyde\dependencies\GEF-zest-3.6.2.zip
>
>       [get]
> http://www.eclipse.org/downloads/download.php?file=/
> tools/gef/downloads/drop
> s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://
> carroll.aset.psu.edu/pub
> /eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-
> zest-3.6.2.zip&mi
> rror_id=546 moved to
> http://archive.eclipse.org/tools/gef/downloads/drops/3.6.
> 2/R201102251600/GEF
> -zest-3.6.2.zip
>
>       [get] .......................
>
>
>
> BUILD SUCCESSFUL
>
> Total time: 5 seconds
>
>
>
>
>
> Some ideas?
>
>
>
>
>
> Jan
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: build IvyDE

Nicolas Lalevée
It has been ages since I have done a build of Eclipse, but like Gintas wrote, there is something wrong with your Eclipse install you are building against, it is missing zest.
I don’t know if you have seen but there is a piece of documentation about building IvyDE there:
http://ant.apache.org/ivy/ivyde/history/latest-milestone/dev/build.html <http://ant.apache.org/ivy/ivyde/history/latest-milestone/dev/build.html>

The hudson-prepare ant task is about what is described in that doc: download stuff and setup the baseLocation property.

Nicolas

> Le 26 mai 2017 à 16:50, Gintautas Grigelionis <[hidden email]> a écrit :
>
> Did you try to run "ant hudson-prepare"? That's supposed to set up the
> entire environment, that is, download PDE and all dependencies (WTP, XSD,
> EMF, GEF and Zest) as drops, then unpack the PDE and all drops on top of
> that, if my understanding is correct. It also should pick up the latest Ivy
> build and update build properties.
>
> Gintas
>
> 2017-05-26 14:53 GMT+02:00 Jan Matèrne <[hidden email]>:
>
>> I tried to get the IvyDE build working.
>>
>> Finally I am getting a
>>
>>
>>
>> [eclipse.buildScript] Some inter-plug-in dependencies have not been
>> satisfied.
>>
>> [eclipse.buildScript] Bundle org.apache.ivyde.eclipse.resolvevisualizer:
>>
>> [eclipse.buildScript]       Missing required plug-in
>> org.eclipse.zest.core_[1.2.0,2.0.0).
>>
>> [eclipse.buildScript]       Missing required plug-in
>> org.eclipse.zest.layouts_[1.1.0,2.0.0).
>>
>>
>>
>> I could download zest via "ant hudson-get-zest"
>>
>>
>>
>> hudson-get-zest:
>>
>>      [get] Getting:
>> http://www.eclipse.org/downloads/download.php?file=/
>> tools/gef/downloads/drop
>> s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://
>> carroll.aset.psu.edu/pub
>> /eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-
>> zest-3.6.2.zip&mi
>> rror_id=546
>>
>>      [get] To:
>> C:\projekte\apache-ant\ivy-ivyde\dependencies\GEF-zest-3.6.2.zip
>>
>>      [get]
>> http://www.eclipse.org/downloads/download.php?file=/
>> tools/gef/downloads/drop
>> s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://
>> carroll.aset.psu.edu/pub
>> /eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-
>> zest-3.6.2.zip&mi
>> rror_id=546 moved to
>> http://archive.eclipse.org/tools/gef/downloads/drops/3.6.
>> 2/R201102251600/GEF
>> -zest-3.6.2.zip
>>
>>      [get] .......................
>>
>>
>>
>> BUILD SUCCESSFUL
>>
>> Total time: 5 seconds
>>
>>
>>
>>
>>
>> Some ideas?
>>
>>
>>
>>
>>
>> Jan
>>
>>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: build IvyDE

Jan Matèrne (jhm)
Nope, haven't read that.
My first contact to a build is always executing the build without any parameters. ;)

I'll have a look, thanks.


Jan

> -----Ursprüngliche Nachricht-----
> Von: Nicolas Lalevée [mailto:[hidden email]]
> Gesendet: Freitag, 26. Mai 2017 17:21
> An: Ant Developers List
> Betreff: Re: build IvyDE
>
> It has been ages since I have done a build of Eclipse, but like Gintas
> wrote, there is something wrong with your Eclipse install you are
> building against, it is missing zest.
> I don’t know if you have seen but there is a piece of documentation
> about building IvyDE there:
> http://ant.apache.org/ivy/ivyde/history/latest-milestone/dev/build.html
> <http://ant.apache.org/ivy/ivyde/history/latest-
> milestone/dev/build.html>
>
> The hudson-prepare ant task is about what is described in that doc:
> download stuff and setup the baseLocation property.
>
> Nicolas
>
> > Le 26 mai 2017 à 16:50, Gintautas Grigelionis
> <[hidden email]> a écrit :
> >
> > Did you try to run "ant hudson-prepare"? That's supposed to set up
> the
> > entire environment, that is, download PDE and all dependencies (WTP,
> > XSD, EMF, GEF and Zest) as drops, then unpack the PDE and all drops
> on
> > top of that, if my understanding is correct. It also should pick up
> > the latest Ivy build and update build properties.
> >
> > Gintas
> >
> > 2017-05-26 14:53 GMT+02:00 Jan Matèrne <[hidden email]>:
> >
> >> I tried to get the IvyDE build working.
> >>
> >> Finally I am getting a
> >>
> >>
> >>
> >> [eclipse.buildScript] Some inter-plug-in dependencies have not been
> >> satisfied.
> >>
> >> [eclipse.buildScript] Bundle
> org.apache.ivyde.eclipse.resolvevisualizer:
> >>
> >> [eclipse.buildScript]       Missing required plug-in
> >> org.eclipse.zest.core_[1.2.0,2.0.0).
> >>
> >> [eclipse.buildScript]       Missing required plug-in
> >> org.eclipse.zest.layouts_[1.1.0,2.0.0).
> >>
> >>
> >>
> >> I could download zest via "ant hudson-get-zest"
> >>
> >>
> >>
> >> hudson-get-zest:
> >>
> >>      [get] Getting:
> >> http://www.eclipse.org/downloads/download.php?file=/
> >> tools/gef/downloads/drop
> >> s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://
> >> carroll.aset.psu.edu/pub
> >> /eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-
> >> zest-3.6.2.zip&mi
> >> rror_id=546
> >>
> >>      [get] To:
> >> C:\projekte\apache-ant\ivy-ivyde\dependencies\GEF-zest-3.6.2.zip
> >>
> >>      [get]
> >> http://www.eclipse.org/downloads/download.php?file=/
> >> tools/gef/downloads/drop
> >> s/3.6.2/R201102251600/GEF-zest-3.6.2.zip&url=http://
> >> carroll.aset.psu.edu/pub
> >> /eclipse/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-
> >> zest-3.6.2.zip&mi
> >> rror_id=546 moved to
> >> http://archive.eclipse.org/tools/gef/downloads/drops/3.6.
> >> 2/R201102251600/GEF
> >> -zest-3.6.2.zip
> >>
> >>      [get] .......................
> >>
> >>
> >>
> >> BUILD SUCCESSFUL
> >>
> >> Total time: 5 seconds
> >>
> >>
> >>
> >>
> >>
> >> Some ideas?
> >>
> >>
> >>
> >>
> >>
> >> Jan
> >>
> >>



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...