junitlauncher hangs after execution tests

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

junitlauncher hangs after execution tests

Dave Brosius-5
I have an ant task using ant 1.10.9 that run <junitlauncher> in forked
mode, the tests run immediately, but then it just hangs with no further
output with either -v or -d


test:
[junitlauncher]
[junitlauncher] Test run finished after 342 ms
[junitlauncher] [         2 containers found      ]
[junitlauncher] [         0 containers skipped    ]
[junitlauncher] [         2 containers started    ]
[junitlauncher] [         0 containers aborted    ]
[junitlauncher] [         2 containers successful ]
[junitlauncher] [         0 containers failed     ]
[junitlauncher] [         2 tests found           ]
[junitlauncher] [         0 tests skipped         ]
[junitlauncher] [         2 tests started         ]
[junitlauncher] [         0 tests aborted         ]
[junitlauncher] [         2 tests successful      ]
[junitlauncher] [         0 tests failed          ]
[junitlauncher]

Any suggestions on how to debug this?


     <target name="test">
         <mkdir dir="${junit_reports.dir}" />
         <junitlauncher printsummary="${junit.printsummary}"
haltonfailure="${junit.haltonfailure}" failureProperty="failed">

             <classpath>
                 <path refid="classes.classpath" />
                 <pathelement path="${test.classes.dir}" />
                 <pathelement
path="${basedir}/../central-strings/prime-strings/target/test_classes" />
                 <pathelement
path="${basedir}/../i18n/target/test_classes" />
                 <pathelement path="${3rdparty.dir}/ant/ant.jar" />
                 <pathelement
path="${3rdparty.dir}/ant/ant-junitlauncher.jar" />
                 <pathelement
path="${3rdparty.dir}/junit5/junit-jupiter-api.jar" />
                 <pathelement
path="${3rdparty.dir}/junit5/junit-jupiter-engine.jar" />
                 <pathelement
path="${3rdparty.dir}/junit5/junit-platform-commons.jar" />
                 <pathelement
path="${3rdparty.dir}/junit5/junit-platform-engine.jar" />
                 <pathelement
path="${3rdparty.dir}/junit5/junit-platform-launcher.jar" />
                 <pathelement
path="${3rdparty.dir}/junit5/opentest4j.jar" />
                 <pathelement
path="${3rdparty.dir}/commons/commons-collections4.jar" />
                 <pathelement
path="${3rdparty.dir}/mockito/mockito-core.jar" />
                 <pathelement
path="${3rdparty.dir}/slf4j/jcl-over-slf4j.jar" />
                 <pathelement path="${3rdparty.dir}/slf4j/slf4j-api.jar" />
                 <pathelement path="${snapshots.dir}/resources.jar" />
             </classpath>

             <testclasses outputdir="${junit_reports.dir}">
                 <fileset dir="${test.classes.dir}"
includes="${tests.patternset}" />
                 <listener type="legacy-xml" sendSysOut="true"
sendSysErr="true"/>
                 <fork dir="${basedir}"
includeAntRuntimeLibraries="false" includeJUnitPlatformLibraries="false">
                     <jvmarg value="-Djava.awt.headless=true" />
                     <sysproperty key="clover.initstring"
value="${clover.dbdir}/${clover.dbfile}" />
                </fork>
             </testclasses>
         </junitlauncher>
     </target>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: junitlauncher hangs after execution tests

Stefan Bodewig
On 2020-12-01, Dave Brosius wrote:

> I have an ant task using ant 1.10.9 that run <junitlauncher> in forked
> mode, the tests run immediately, but then it just hangs with no
> further output with either -v or -d

Could this be https://bz.apache.org/bugzilla/show_bug.cgi?id=64733 ?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]